Enum khronos_egl::LoadError[][src]

pub enum LoadError<L> {
    Library(L),
    InvalidVersion {
        provided: Version,
        required: Version,
    },
}

Variants

Library(L)

Tuple Fields

0: L

Something wrong happend while loading the library.

InvalidVersion

Fields

provided: Version
required: Version

The provided version does not meet the requirements.

Trait Implementations

Formats the value using the given formatter. Read more

Formats the value using the given formatter. Read more

The lower-level source of this error, if any. Read more

🔬 This is a nightly-only experimental API. (backtrace)

Returns a stack backtrace, if available, of where this error occurred. Read more

👎 Deprecated since 1.42.0:

use the Display impl or to_string()

👎 Deprecated since 1.33.0:

replaced by Error::source, which can support downcasting

Auto Trait Implementations

Blanket Implementations

Gets the TypeId of self. Read more

Immutably borrows from an owned value. Read more

Mutably borrows from an owned value. Read more

Performs the conversion.

Performs the conversion.

Converts the given value to a String. Read more

The type returned in the event of a conversion error.

Performs the conversion.

The type returned in the event of a conversion error.

Performs the conversion.